Page 3 of 3 FirstFirst 123
Results 61 to 71 of 71

Thread: Camera left out in the torrential rain...

  1. #61
    Join Date
    Jan 2010
    Location
    Suburb of Seattle, WA
    Posts
    929
    WOOT! Tears of joy.
    Shar

    Just passing through.

    PSE-9 and CS5 on Windows 7
    PC
    Canon Rebel xsi

  2. #62
    Join Date
    Mar 2006
    Location
    England
    Posts
    4,009
    Phew! I'm glad you didn't need to 'cook' it - you'd have to be brave to do that!!

  3. #63
    Join Date
    Aug 2008
    Location
    Hoover, AL
    Posts
    30,358
    Great news! So glad it works!
    Amy

    my gallery

    My stuff: Nikon D700; Nikkor f2.8 24-70mm, f2.8 105mm, and f1.4 50 mm lenses; Tamron f2.8 70-200; Photoshop CC, Lightroom, iMac, MacBook

    DDblinkie! photo DDblinkie_zps0593abf9.gif

  4. #64
    Join Date
    Dec 2007
    Location
    Pennsylvania
    Posts
    78,073
    I am so glad for you Esther!!!!
    Anke







    My gear:
    Nikon: D700, 50mm 1.4, 24-70 mm 2.8, 17-35 mm 2.8, 70-200 2.8, 85mm 1.4
    Tamron:18-270mm 3.5-6.3, 90mm 2.8,
    LR 5 (CC), CS6 on a 17" MacBookPro.
    Member NAPP
    My blog
    My gallery

  5. #65
    Join Date
    Feb 2008
    Location
    Outside of Atlanta
    Posts
    5,597
    Totally fantastic good news for you Esther! Hurray!
    Kerry

    Keep on the sunny side of life

    Canon 5D Mark II
    Photoshop CS4

    My Gallery

    my flickr/

    my website


  6. #66
    Join Date
    Mar 2008
    Location
    Israel
    Posts
    15,599
    Well done!!! That is great news!!!
    * Aino *

    My gallery



    : Nikon D4S & Nikon Df with various lenses.
    : Lightroom and PSCS6

  7. #67
    Join Date
    Aug 2008
    Location
    Colorado, USA
    Posts
    11,042
    Esther--Hope it's back and operable SOON! (if not, insurance coverage??)
    marnie


  8. #68
    Join Date
    Jan 2008
    Location
    A rural city in Victoria, Australia
    Posts
    20,602
    It's all good Marnie! Thanks for asking. My explanation is buried somewhere higher in this thread.
    Camera: Canon 7D, Olympus OM-D E-M5, Olympus TG2 (point and shoot)
    Lenses (for the 7D): Tamron F2.8 28-75mm, Tamron 70-300mm f/4-5.6 and Sigma 50mm f/1.4
    Software: CS6.0, LightRoom 5, ACDSee 14
    Platform: PC
    My blog: snippets


  9. #69
    Join Date
    Mar 2008
    Location
    Atlanta, GA
    Posts
    951
    I'm so sorry to hear about the camera. One of my best friends did the exact same thing. I'm coming into this story so late in the game but I'm dying to know if it worked! Good luck!

  10. #70
    Join Date
    Mar 2008
    Location
    Atlanta, GA
    Posts
    951
    Sorry...I'm kind of new to threads and didn't see the additional pages after the first one. Sooooo glad it worked for you....k

  11. #71
    Join Date
    Dec 2005
    Location
    Tampa Bay, Florida
    Posts
    11,368
    How did I miss this as well? So glad it all worked out. I know something about drying out cameras before rainy season.

Page 3 of 3 FirstFirst 123

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •